Jump to content
Satan

Amplifier Handler - Serialization

Recommended Posts

System Name: Amplifier Handler - Serialization

 

Credits:

@Billy, System idea;

@KONG, System idea;

@Satan, Release and debug of system;

 

Introduction:

Our players get annoyed when we restart the server or they get DC and lose the bonus from their AMP. The purpose of this system is to save AMP bonuses in a .txt file and maintain the bonus persistence even if the player DC or the server restarts... Also a global function has been made for all the AMP's and of course the player receives notice of the duration of the bonus or when it ends.

 

Change-Logs:

- Release of scripts v1.0 (03/13/2018)

- Original scripts by Billy and KONG amplifier.lua

  • Like 1

Share this post


Link to post
Share on other sites

Functions that need to be replace from this handler will fix errors and make call the amplifier statelv from it's functions too. A example of error is the ship experience which is not granted when u use amp, where on this handler it fixed.

  • Like 1

Share this post


Link to post
Share on other sites
On 8/15/2018 at 2:52 PM, Satan said:

Functions that need to be replace from this handler will fix errors and make call the amplifier statelv from it's functions too. A example of error is the ship experience which is not granted when u use amp, where on this handler it fixed.

I'm having a problem that im not gaining double exp when using amp, not getting errors at lua_err tho.. im using a custom_timer same name as on script "player_timer"

Share this post


Link to post
Share on other sites
35 minutes ago, Satan said:

You must replace original amplifiers function to new one that on handler, otherwise it will not work for sure. Timer just for ads system..

I replaced the exp_and_lvl & skilleffect functions, and iteminfo item_use function to the one on amp handler but it wont work, no errors at lua_err

Share this post


Link to post
Share on other sites
14 hours ago, Satan said:

You probably forgot something on installation, check path to data or read whole codes and installation process again. 

I went through all and add everything but still wont work, it wont even show the bickernotice when i click the amp nor add double exp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×