Jump to content

Recommended Posts

Hello @ShadowJr,

 

1) When I created a character and relogged into the account, the character disappears;

2) When I try to enter the map with a newly created character, I get an error: "server link operation integrality error".


Share this post


Link to post
Share on other sites

Hello @V3ct0r  Did you add this to the DB?
 

USE [gamedb];

ALTER TABLE gamedb.dbo.guild add bank varchar(8000);

alter table gamedb.dbo.guild add gold bigint default(0) NOT NULL;

alter table gamedb.dbo.character drop constraint DF_character_guild_permission;
alter table gamedb.dbo.character alter column guild_permission bigint;
ALTER TABLE gamedb.dbo.character ADD CONSTRAINT DF_character_guild_permission DEFAULT 0 FOR guild_permission;

alter table gamedb.dbo.guild add 
PDEF int default(0) NOT NULL,
MSPD int default(0) NOT NULL,
ASPD int default(0) NOT NULL,
MXATK int default(0) NOT NULL,
DEF  int default(0) NOT NULL,
HIT  int default(0) NOT NULL,
FLEE int default(0) NOT NULL,
HREC int default(0) NOT NULL,
SREC int default(0) NOT NULL,
MXHP int default(0) NOT NULL,
MXSP int default(0) NOT NULL,
level int default(0) NOT NULL;

alter table gamedb.dbo.guild add colour int default(-1) NOT NULL;
alter table gamedb.dbo.guild add icon int default(0) NOT NULL;

CREATE TABLE holding

  id INT NOT NULL IDENTITY(1,1) PRIMARY KEY,
  bag VARCHAR(8000) NOT NULL,
);

alter table gamedb.dbo.account add IMP int default(0);

alter table gamedb.dbo.character add chatColour int default(-1) NOT NULL

 

Are you using the last files I sent? I just tested here, it's all working fine!

Edited by ShadowJr
  • Thanks 1

Share this post


Link to post
Share on other sites

@ShadowJr,

 

Now it works, thank you!

cosuccess.png

 

How different are these files from CO ones?


Share this post


Link to post
Share on other sites

Hello @ShadowJr,

 

I have not abandoned the project, but there is no news yet.

 

Thank you for your interest!

  • Thanks 1

Share this post


Link to post
Share on other sites

Hello @farofa0,

 

On 8/9/2022 at 7:27 PM, farofa0 said:

Does this work on 1.36? Or only on 1.38?

It works with both 1.36 and 1.38 versions. 

 

Quote

I couldn't get it to work. I get an incorrect password error.

Have you installed these mods for your server and client?

 

Client:

 

GateServer:

 

 

 


Share this post


Link to post
Share on other sites
On 8/15/2022 at 8:42 AM, V3ct0r said:

Have you installed these mods for your server and client?

I didn't installed the gateserver mod since it doesn't have a version for 1.36.

I tried to use this stall system without installing the gateserver mod by changing "ip_mod" variable from config file to false.

 

Today I installed the mod on the gateserver just to be sure but it didn't work. The gateserver shows me that the .exe version is not supported.

Share this post


Link to post
Share on other sites
11 hours ago, farofa0 said:

I didn't installed the gateserver mod since it doesn't have a version for 1.36.

I tried to use this stall system without installing the gateserver mod by changing "ip_mod" variable from config file to false.

 

Today I installed the mod on the gateserver just to be sure but it didn't work. The gateserver shows me that the .exe version is not supported.

Are you sure that pkodev.mod.stallserver is successfully loaded by your Game.exe? Start Game.exe using the following way:

system\Game.exe startgame > output.txt

In the root client folder will appear the file output.txt with information about loaded mods.


Share this post


Link to post
Share on other sites
3 hours ago, V3ct0r said:

Are you sure that pkodev.mod.stallserver is successfully loaded by your Game.exe?

You're right. It is not being loaded. I'm using version 13x_3. (All other mods are loading normally.)

Share this post


Link to post
Share on other sites

@V3ct0r, I did some tests based on the five versions of game.exe I found.

 

The client mod actually only loaded in version 0, 1 and 2. Versions 3, 4 and 5 did not find the corresponding mod.

 

I'm testing version number 0 now. But nothing happens when i enter the password. It looks like it logs in, but the character selection screen never shows up. 

 

Maybe i configured it wrong. Can you confirm to me that I can login in 1.36 without using the gate server extension?

Share this post


Link to post
Share on other sites
On 8/19/2022 at 3:48 AM, farofa0 said:

The client mod actually only loaded in version 0, 1 and 2. Versions 3, 4 and 5 did not find the corresponding mod.

Hello @farofa0,

 

Yes, there was such a problem. I fixed it and sent updates to GitHub.

 

On 8/19/2022 at 3:48 AM, farofa0 said:

I'm testing version number 0 now. But nothing happens when i enter the password. It looks like it logs in, but the character selection screen never shows up. 

Works fine for me. Make sure that ip_mod = false in pkodev.stallserver.cfg. Also make sure you have built the pkodev.stallserver.exe from the latest version sources.

 

18 hours ago, ShadowJr said:

Hello @V3ct0r it's been a while since the last update, gave up on making this system compatible with CO Src?

Hello @ShadowJr,

 

Unfortunately, I ran into some difficulty designing the server architecture so that it can work with the corsair version. I also don't have much time to work on a project lately. I apologize for such a long wait.

 

 

 

 

 


Share this post


Link to post
Share on other sites
10 hours ago, V3ct0r said:

Hello @farofa0,

 

Yes, there was such a problem. I fixed it and sent updates to GitHub.

 

Works fine for me. Make sure that ip_mod = false in pkodev.stallserver.cfg. Also make sure you have built the pkodev.stallserver.exe from the latest version sources.

Thanks for fixing the client mod. It's loading correctly in my exe now.

 

However I still can't log in. I recompiled the stallserver again and checked that ip_mod = false. But the same problem persists. I took a look at the log. And as soon as I try to log in I get this error:

"[2E94 | 18:41:16] Exception 'linear_buffer_exception' is occurred on socket read callback: LinearBuffer::write(): Not enough space or zero bytes requested for writing operation!"

 

Can you help me? What could I be doing wrong?

 

Share this post


Link to post
Share on other sites
11 hours ago, farofa0 said:

Thanks for fixing the client mod. It's loading correctly in my exe now.

 

However I still can't log in. I recompiled the stallserver again and checked that ip_mod = false. But the same problem persists. I took a look at the log. And as soon as I try to log in I get this error:

"[2E94 | 18:41:16] Exception 'linear_buffer_exception' is occurred on socket read callback: LinearBuffer::write(): Not enough space or zero bytes requested for writing operation!"

 

Can you help me? What could I be doing wrong?

 

Does your game client have any modifications? For example, anti WPE protection?


Share this post


Link to post
Share on other sites
3 hours ago, farofa0 said:

Not that I know of, I'm using clean client and server from here: https://mega.nz/folder/OUMUgTYb#jtCsqh7halK_O9uzWyaG0g

Send your Game.exe from client.


Share this post


Link to post
Share on other sites
On 8/25/2022 at 10:08 PM, farofa0 said:

Here it is: https://mega.nz/file/ahpGjSAJ#LdXrZz6CohK_GvKsHRbMdDRtsjNtkaZhri6VSCtM0pE

But I don't think it's anything related to the .exe, since I've tried with other versions and the same error occurred.

Just checked your Game.exe with the pkodev.stallserver.exe build from the latest source code revision. Works fine for me.

 

On 9/4/2022 at 6:24 PM, gunnapong said:

I have a problem. WPE cannot be used. I would like to turn off WPE protection. Where do I change the source? @V3ct0r

The current version of pkodev.stallserver does not support Game.exe with built-in WPE protection.


Share this post


Link to post
Share on other sites
2 hours ago, emofc said:

its now fixed and works good out of errors STALL SERVER? 

Hello @emofc,

 

Nobody has tested properly.


Share this post


Link to post
Share on other sites
1 minute ago, V3ct0r said:

Hello @emofc,

 

Nobody has tested properly.

I will open a server with your files,im trying now to attach new stall server on your files.

  • Thanks 1

Share this post


Link to post
Share on other sites
5 minutes ago, emofc said:

I will open a server with your files,im trying now to attach new stall server on your files.

Great, I will wait for your feedback.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...