Jump to content
Fritt

Community Source Code Development - Server / Client

Recommended Posts

14 hours ago, 1g0rS1lv4 said:

I don't know if anyone else had this problem, after a while of online server, being giving error to create character, says that the nickname already exists but it does not exist in the database.

I don't know how to replicate it happened to me a few times, at random times.

image.png

I got this problem, when i create new Account and login using AutoLogin

Share this post


Link to post
Share on other sites

Hello, anyone experiencing this ? Can't see the lamb mount and I started copying stuff from one client to another, but always ending up with the working client showing a blue screen.

 

image.png.ec33dc43e7cd0f8c8880501f3e6a33da.png

 

 

any toughts ?

Share this post


Link to post
Share on other sites
33 minutes ago, blankode said:

Hello, anyone experiencing this ? Can't see the lamb mount and I started copying stuff from one client to another, but always ending up with the working client showing a blue screen.

 

image.png.ec33dc43e7cd0f8c8880501f3e6a33da.png

 

 

any toughts ?

did you throw MindPower3D_D8R in your system folder? or if you are using Corsair resolutions, you may be missing the CameraConf1024.clu file.

Edited by 1g0rS1lv4

Share this post


Link to post
Share on other sites
1 hour ago, 1g0rS1lv4 said:

did you throw MindPower3D_D8R in your system folder? or if you are using Corsair resolutions, you may be missing the CameraConf1024.clu file.

Yes I did, I got every file that you mentioned.

 

With compiled game.exe I can't see characters before entering the game, with the game.exe that came with the client it works ok.

The main reason I have posted is because the mounts aren't rendering, and I have tried multiple things (client-related) but not a single one working.

 

A hint would be appreciated.

 

image.png.44b14c3d77cb01ba3af501e16ee8de88.png

^thats why I posted in first place.

 

image.png.3fd0d90161c58404272294815922fcd0.png

Is that file required or random error ?

 

 

Edited by blankode

Share this post


Link to post
Share on other sites
29 minutes ago, Fritt said:

Has anyone managed to fix the Guild Disband & Creation Crash?

Guild Disband

https://gyazo.com/9ba2dc88fc77f2b715804ffa08ff52ea

Guild Creation

https://gyazo.com/7961d2b4b069615e08ee1331ae885c27

soon post here, not 100%

still crash sometimes when creating or deleting guild, but now less often.

Edited by 1g0rS1lv4
  • Like 2

Share this post


Link to post
Share on other sites
Bug Title: Switch Item Flood Crashes all people Clients on the range
Bug Description: Switching items crashes all players clients around you
How to replicate: Switch items using F-Panel so you can flood the system and all players around you will Crash
Status: OPEN
Author (whoever that fixes it):

 

Share this post


Link to post
Share on other sites
Bug Title: when logging out of his character he disappears
Bug Description: when logging out of his character he disappears
How to replicate: when logging out of his character he disappears
Status: CLOSED
Author (whoever that fixes it): Eviles and GustavoHMA Reported Error location.

opens the ItemContent.h file located at: Client\Common\common\include

 search for the function:   

short    sNeedLv;

and above it add this:

bool bIsLock;

getting like this:

image.png.e53d779537e6eaf23134655aa7bfa99e.png

now search for this function:

inline SItemGrid :: SItemGrid (short sId, short sINum)

find:

sNeedLv = 0;

and above it add this:

bIsLock = 0;

getting like this:

 

image.png.484ebd4675f3cca662d000d214fdd570.png

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites
22 hours ago, 1g0rS1lv4 said:
Bug Title: when logging out of his character he disappears
Bug Description: when logging out of his character he disappears
How to replicate: when logging out of his character he disappears
Status: CLOSED
Author (whoever that fixes it): Eviles and GustavoHMA Reported Error location.

opens the ItemContent.h file located at: Client\Common\common\include

 search for the function:   

short    sNeedLv;

and above it add this:

bool bIsLock;

getting like this:

image.png.e53d779537e6eaf23134655aa7bfa99e.png

now search for this function:

inline SItemGrid :: SItemGrid (short sId, short sINum)

find:

sNeedLv = 0;

and above it add this:

bIsLock = 0;

getting like this:

 

image.png.484ebd4675f3cca662d000d214fdd570.png

Yep, this is the missing thing in common. AKA item deleveler.

  • Like 1

Share this post


Link to post
Share on other sites
Bug Title: Bank PIN Value
Bug Description: The Bank NPC is missing Bank PIN Value
How to replicate: Clicking any Bank NPC to open bank through PIN Value it won't show anything, its client src problem.
Status: OPEN
Author (whoever that fixes it):

 

Share this post


Link to post
Share on other sites

Bug Title: Blank texture upon character switch after trying item mall

Bug Description: When you wear armor, try an item mall apparel on you,switch your character/relog, the texture of the item is white 

How to replicate: Equip an armor (tested with Newbie Vest), try an item mall apparel  then relog; it will have white texture (doesnt work all the time, only sometimes)

Status: OPEN

Author (whoever that fixes it):


image.png.e4260ab7e9a720cc3efe79cfedcd1a39.png

 

Edited by Myrddin

Share this post


Link to post
Share on other sites

Bug Title: Cannot Create Guild

Bug Description: Cannot create a guild. No error pops up and nothing happens

How to replicate: Have stone of oath, go to icicle to create a guild, nothing happens

Status: OPEN

Author (whoever that fixes it):

 

Edit: Nvm, I was too dumb to figure out you need 10m.

Edited by Myrddin

Share this post


Link to post
Share on other sites

Bug Title: Tickets do not always work

Bug Description: Sometimes I can use Tickets (to Argent, Icicle, Shaitan) to teleport. Other times, nothing happens and item is not consumed

How to replicate: Double click one of the tickets. Most of the time nothing happens

Status: OPEN

Author (whoever that fixes it):

Share this post


Link to post
Share on other sites
51 minutes ago, Myrddin said:

Bug Title: Cannot Create Guild

Bug Description: Cannot create a guild. No error pops up and nothing happens

How to replicate: Have stone of oath, go to icicle to create a guild, nothing happens

Status: OPEN

Author (whoever that fixes it):

to create a guild in addition to stone you have to have 10M.

Share this post


Link to post
Share on other sites
51 minutes ago, Myrddin said:

Bug Title: Tickets do not always work

Bug Description: Sometimes I can use Tickets (to Argent, Icicle, Shaitan) to teleport. Other times, nothing happens and item is not consumed

How to replicate: Double click one of the tickets. Most of the time nothing happens

Status: OPEN

Author (whoever that fixes it):

Thats Lua problem, check ur Tickets.lua (bcz if you use &updateall ingame all tickets will work after that) so just take the fix from other thread.

Share this post


Link to post
Share on other sites
50 minutes ago, Myrddin said:

Bug Title: Tickets do not always work

Bug Description: Sometimes I can use Tickets (to Argent, Icicle, Shaitan) to teleport. Other times, nothing happens and item is not consumed

How to replicate: Double click one of the tickets. Most of the time nothing happens

Status: OPEN

Author (whoever that fixes it):

the tickets if I'm not mistaken you have to forward all the ItemUse of the tickets found on iteminfo for a new function that can be found in lua / plugins / ticket.lua 

something like that I'm not on the computer.

Sorry for bad inglish.

Share this post


Link to post
Share on other sites

I'll post here more things as I find them to keep track, and if I find a fix on the forum I'll remvoe them. Is it ok?

 

Bug Title: Names do not appear correctly in chat

Bug Description: Sometimes, names do not appear at all in chat. I can't see what others write in other chats except normal (world, guild, etc.)

How to replicate: Have someone write in World chat, whisper, or guild

Status: OPEN

Author (whoever that fixes it):

 

 

 

Edited by Myrddin

Share this post


Link to post
Share on other sites
On 4/26/2020 at 4:46 AM, 1g0rS1lv4 said:

the tickets if I'm not mistaken you have to forward all the ItemUse of the tickets found on iteminfo for a new function that can be found in lua / plugins / ticket.lua 

something like that I'm not on the computer.

Sorry for bad inglish.

Nvm, fixed this. It wasn't a bug, it was just my brain being stupid.

Edited by Myrddin

Share this post


Link to post
Share on other sites
Bug Title: Flood buttons/exp/guild color/ addexpguild
Bug Description: Flood buttons/exp/guild color/ addexpguild spamming sql while many players doing /killing monsters or quests
How to replicate: Flooding buttons/exp/guild color/ addexpguild spams sql while many players doing /killing monsters or quests
Status: OPEN
Author (whoever that fixes it):

 

Share this post


Link to post
Share on other sites
20 hours ago, Myrddin said:

Bug Title: Pet Skills do not work

Bug Description: From what I've checked, Standard Meditation & Berserk do not work. Probably others don't either.

How to replicate: Train your pet novice & standard med & berserk and go punch something or cast on it. Double damage never happens and sp recovery doesn't increase

Status: CLOSED

Author (whoever that fixes it): Myrddin

Found the fix.

In CO files, you equip the pet. In server's functions.lua, the system checks if the pet is on the 2nd slot in the inventory

 

So here's the fix:

 

Go to resources > scripts > calculate > functions.lua

Find this line: (it's in function CheckHaveElf ( role ))

local Item = GetChaItem ( role , 2 , 1  ) 

As you can see, it checks the fairy on the 2nd slot of the 1st row. Now we're going to make it check if it is equipped in the fairy slot.

Replace it with this:

local Item = GetEquipItemP(role ,16)

This checks if you have any item equipped in the 16th slot (the Fairy slot, if you will) on your inventory.

Save it, and reload all your .lua files (or restart server) and it should work!

Edited by Myrddin

Share this post


Link to post
Share on other sites
On 4/23/2020 at 10:49 PM, KONG said:

Yep, this is the missing thing in common. AKA item deleveler.

If that's the fix why the Item Deleveler aint working with the this client? Missing anything else?

Share this post


Link to post
Share on other sites
Bug Title: Ship Upgrade
Bug Description: Unable to upgrade ship level
How to replicate: Buy Ship and try Upgrade it through npc it will not work
Status (pending / close / open): OPEN
Author (whoever that fixes it): 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...