Jump to content
gatero

Create a new Tales of Pirates 1.36 Private Server Guide

Recommended Posts

 

 

Hello again guys,
I created this video with the idea of promoteing again the tales of pirates private server community.

Here you can see my web service related post:

 

Server Files/Game/My Webserver consumers: 

https://drive.google.com/open?id=1A4O161L36d0qJx2AnCksm5crg0Nktdt5


Microsoft SQL SERVER 2014/2017 Installation Guides i used:

 

Good Lucks guys

Edited by gatero
  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, Unknown said:

 

Okey so where you put your SQL Instanse name try adding \SQLEXPRESS. Ex. db_ip = DESKTOP-AJRG37L\SQLEXPRESS

If you install the full version of Mssql the instanse name is as defined in the installation. By default it is your Computer Name. 

For sql express instalation, the sufix \SQLEXPRESS is included in the Instanse Name.

You should edit your other gameservers, account server and group server with this new db_ip.


Good Luck

Edited by gatero

Share this post


Link to post
Share on other sites
6 minutes ago, gatero said:

Okey so where you put your SQL Instanse name try adding \SQLEXPRESS. Ex. db_ip = DESKTOP-AJRG37L\SQLEXPRESS

If you install the full version of Mssql the instanse name is as defined in the installation. By default it is your Computer Name. 

For sql express instalation, the sufix \SQLEXPRESS is included in the Instanse Name.

You should edit your other gameservers, account server and group server with this new db_ip.


Good Luck

AccountServer,GateServer,GroupSever works with no errors with computer name, except GameServer.

Adding SQLEXPRESS doesn't helps, after that none of them doesn't start properly. Any ideas?

Edited by Unknown

Share this post


Link to post
Share on other sites
7 hours ago, Unknown said:

Update: Installed Win7 64bit SP1

[DB]
db_ip = WIN-7Q8OFUTQVMI\SQLEXPRESS
db_usr = top
db_pass = EZCpyYOZVofugqDFBZrLKw==

 

It still gives same error. 

Did you changed the name of the GameDB Database before creating it? Make sure you wrote it right. If this is not the problem i need some more information as i never got that error. 

Share this post


Link to post
Share on other sites
7 hours ago, Unknown said:

Update: Installed Win7 64bit SP1

[DB]
db_ip = WIN-7Q8OFUTQVMI\SQLEXPRESS
db_usr = top
db_pass = EZCpyYOZVofugqDFBZrLKw==

 

It still gives same error. 

Make sure you made sql password for ur user with 9 words no more no less and encrypt it.
Also try at db_ip = .\SQLEXPRESS

Share this post


Link to post
Share on other sites
2 hours ago, FapFap said:

Make sure you made sql password for ur user with 9 words no more no less and encrypt it.
Also try at db_ip = .\SQLEXPRESS

I did, i reinstalled OS, installed new SQLEXPRESS, typed WIN-7Q8OFUTQVMI\SQLEXPRESS with correct user and pass. Only GameServer doesnt work

Share this post


Link to post
Share on other sites
2 hours ago, gatero said:

Did you changed the name of the GameDB Database before creating it? Make sure you wrote it right. If this is not the problem i need some more information as i never got that error. 

I did everything just like in your video. Only GameServer doesnt start properly

Share this post


Link to post
Share on other sites
1 minute ago, Unknown said:

It has all roles marked, but on GameDB properties -> Owner: DESKTOP-AJRG37L\Admin

Okey thats why.

You have to delete de GameDB with the user you created the database, disconnect from database and connect again but not with windows auth. But with SQL Server Auth. Then create again the GameDB and give user top privileges and try again.

 

image.png.f55c3b59bf5a97333346b9ffda2a90e2.png

image.png.e826a8609a819e6d5d304673d2c75b6d.png

image.png.018dc0f1609a7a2dced8a704c620a65c.png

image.png.a396506334d960ec1df792ba5fe3dce4.png

 

See login user at the top right?

Share this post


Link to post
Share on other sites
14 minutes ago, gatero said:

Okey thats why.

You have to delete de GameDB with the user you created the database, disconnect from database and connect again but not with windows auth. But with SQL Server Auth. Then create again the GameDB and give user top privileges and try again.

 

image.png.f55c3b59bf5a97333346b9ffda2a90e2.png

image.png.e826a8609a819e6d5d304673d2c75b6d.png

image.png.018dc0f1609a7a2dced8a704c620a65c.png

image.png.a396506334d960ec1df792ba5fe3dce4.png

 

See login user at the top right?

image.png.00ee6d3410704c5651b3b7ee919dafa2.png

After this one i logged in with windows authentification and created GameDB.

 

image.png.b8060aed7c8d6ee636b19fb1906a3fb2.png

Still gives same error

image.png.d41ee4d30e875a83341b377f9d96fd28.png

Edited by Unknown

Share this post


Link to post
Share on other sites

What are u doing guys? If Groupserver connected to db ->trouble not in db

 

Why you use this:

db_ip = WIN-7Q8OFUTQVMI\SQLEXPRESS

 

If name of Your copy of sql is:

Desktop-g93d8bp\sqlexpress

 

Also Run gs "as admin" 

Share this post


Link to post
Share on other sites

Why are you using 2014? 🤔🤨

 

I didn't notice you used my guide / files until after I had already posted here🤦‍♂️ 😁

 

At everyone else:

 

I fixed the spoiler in case you weren't able to find what you needed to do any of this. :cool:

 

Everything is working fine for me using 64-bit Win 10 and SQL Server 2017 Express. 👍

 

Edited by Hardmuscle
  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

I followed the SQL 2017 installation guide and everything went well until I was told to run the gameserver, groupserver, and all those

 

I had an issue with group server : ╬─╝■:\Edition\Edition_kop\1.37\Eng__Singapore\Server\GroupServer\src\GroupServerAppInit.cpp ╨╨:107 ├Φ╩÷:Unable to connect database

 

Game server also gives me an error: Database [GameDB] Connect Failed!, ERROR REPORT [39854656]

 

game server 2, 3, 4 also ive me similar error with different error report numbers.

 

I think it has to do with the fact that I changed the directory from C: to D:, since that's my main storage unit. I changed the files from C: to D: in both Account Server and GameDB, the files we use in SQL. Are there other files I should be editing from C: to D:? 

 

Thank you

 

 

Edit: Fixed. Turns out I didn't notice I needed to provide a specific password (Y87dc#$98) for the passwords in the other files to work. Changed sa password from SQL and it works now.

 

Edited by dafoor

Share this post


Link to post
Share on other sites
On 10/12/2018 at 6:31 AM, dafoor said:

Hi,

 

I followed the SQL 2017 installation guide and everything went well until I was told to run the gameserver, groupserver, and all those

 

I had an issue with group server : ╬─╝■:\Edition\Edition_kop\1.37\Eng__Singapore\Server\GroupServer\src\GroupServerAppInit.cpp ╨╨:107 ├Φ╩÷:Unable to connect database

 

Game server also gives me an error: Database [GameDB] Connect Failed!, ERROR REPORT [39854656]

 

game server 2, 3, 4 also ive me similar error with different error report numbers.

 

I think it has to do with the fact that I changed the directory from C: to D:, since that's my main storage unit. I changed the files from C: to D: in both Account Server and GameDB, the files we use in SQL. Are there other files I should be editing from C: to D:? 

 

Thank you

 

 

Edit: Fixed. Turns out I didn't notice I needed to provide a specific password (Y87dc#$98) for the passwords in the other files to work. Changed sa password from SQL and it works now.

 

Try run it as Administrator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×